15 April 2013

Install Ruby 2.0.0 on Backtrack

Ruby adalah salah satu bahasa pemrograman yang sering dipakai untuk membangun beberapa tools hacking. Di backtrack, bahasa pemrograman ini secara default sudah terinstall dengan baik. Mengingat banyak tools yang dibenamkan pada OS pentest ini berbasiskan ruby. Salah satu yang terkenal adalah Metasploit, framework untuk membantu mengeksploitasi sistem ini dibangun menggunakan ruby.
Versi yang telah dipaketkan dalam OS backtrack terakhir yaitu 5r3 adalah ruby versi 1.8.7. Versi 1.8.7 juga ditambahi dengan versi 1.9.2 untuk mendukung program lain yang membutuhkan versi lebih tinggi. Ini mengingat beberapa tools masih menggunakan versi 1.8.7 sementara yang lain sudah ke versi 1.9.2. Namun ada kalanya versi 1.9.2 ini mengalami masalah, terutama karena rumitnya sistem yang mengadaptasi tiap tools, sehingga kadang error menyertai pengguna backtrack saat ingin menggunakan tools yang membutuhkan versi 1.9 atau lebih tinggi. Alternatifnya kita bisa memeriksa ulang instalasi ruby versi yang lebih tinggi atau menambahkan versi yang tinggi ke sistem atau lazim disebut upgrade.
Salah satu alternatif untuk meng-upgrade ruby adalah melalui RVM (Ruby Version Manager). RVM membantu kita memanajemen versi ruby yang telah terinstall di dalam sistem kita. Baik, mari kita memulai menginstalasikan ruby versi yang lebih tinggi dari 1.9, saya akan menggunakan versi 2.0.0.
Pertama-tama kita instalasikan dependensi dari RVM itu sendiri, gunakan perintah di bawah ini, sebelumnya lakukan update terlebih dahulu.
root@h3:~# apt-get update && apt-get install libreadline6-dev libyaml-dev libgdbm-dev libffi-dev
Setelah itu kita mulai menginstall RVM dengan bantuan curl.
root@h3:~# \curl -L https://get.rvm.io | bash -s stable --ruby
Kemudian kita tambahkan RVM agar bisa dieksekusi dalam perintah terminal.
root@h3:~# source /usr/local/rvm/scripts/rvm
Kini RVM sudah terinstall dengan baik pada backtrack, kita bisa melihat versi terbaru RVM dengan perintah.
root@h3:~# rvm -v
Saya memilih menggunakan Ruby 2.0.0 yang barusan kita install sebagai default, gunakan perintah berikut.
root@h3:~# rvm use 2.0.0
Kini saya bisa menjalankan WPScan yang sebelumnya tidak bisa saya jalankan menggunakan Ruby 1.8.7. Untuk manual instalasi RVM silahkan menuju ke https://rvm.io/rvm/install. "i'm not a pentester, but just a beginner".
Happy Analyst!

2 comments:

Ahmeda Rusdan said...

Bro em facing this problem when i typed this "rvm install ruby-2.0.0-p353"

Searching for binary rubies, this might take some time.
Found remote file https://rvm.io/binaries/ubuntu/10.04/x86_64/ruby-2.0.0-p353.tar.bz2
Checking requirements for ubuntu.
Installing requirements for ubuntu.
Updating system...................................................................
Error running 'requirements_debian_update_system ruby-2.0.0-p353',
please read /usr/local/rvm/log/1385994037_ruby-2.0.0-p353/update_system.log
Requirements installation failed with status: 100.

can u help me ?

cutu said...

Sorry bro, i'm not use backtrack anymore. Maybe you can use the newest pentesting OS, Kali Linux??